I Have Connected It As Instructed But No Light Is Coming On

First, try completing disconnecting the system and attempting a re-installation, this will help you ensure you have installed it correctly with all plugs firmly attached.

If connected the wrong way, the system will not receive power and the LED will not illuminate, thus preventing the engine from starting or operating correctly. Check your connector installation and see if the LED now illuminates allowing the vehicle to start.

I Have Connected It As Instructed But The Engine Does Not Start

If you install the CRTD4 Diesel Tuning box into your vehicle and the engine does not start, you may be experiencing a poor connection. Please recheck all connections to engine and check that the surface mounted LED on the tuning box illuminates when the ignition is on. We would recommend you try re-affixing your connectors.

I Have Installed It Successfully But An Engine Light Is Now Lit On The Dashboard

Have you changed the unit operating mode to maximum setting? Did you drive the vehicle for 10 miles between increasing to each of the modes? If not then you may need to step back down to the starting mode, 4, and follow our instructions for adjusting your Tuning Box.

If you followed the adjustment instructions and still have a warning light at the maximum setting, adjust the box back to setting 4 and contact our customer services for further guidance.

I Have Installed It Successfully But See No Difference In Performance

You may have not installed the product correctly, we would suggest first attempting a re-installation of the product in order to ensure it has been correctly installed.

Following this, we would suggest increasing the box mode to its maximum, please refer to your supplied instructions on how to do this.

If you have done this and feel you still see no improvements please contact us for further guidance.

I Have Installed It Successfully But There Is Excessive Engine Smoking

If you start your vehicle after attaching the Diesel Tuning box and experiencing excessive smoking, this could be a simple case of personalising and adjusting the unit to suit your exact fuelling characteristics. Adjust the settings on the box to the left one position, then road test the vehicle.

Excessive exhaust smoke could also be caused by a split in an intercooler hose so a visual check of these components is highly recommended.

I Have Used The Box For Several Months Now A Warning Light Has Come On, What Should I Do?

First, disconnect and re-install the product which will ensure no connections have come loose or any damage has occurred to the box or connection harness.

When re-installing the product, set the tuning box to its standard setting of level 4. If the problem re-occurs contact our technical department for further guidance.

If re-installed and no problems occur at level 4, move the tuning box up to its maximum by one setting every ten miles at a time.

I Have Used The Box For Several Months But It Feels Now As If It Is Not Working?

Users of our products can become accustomed to additional power and torque over several months or years of ownership.

First we would suggest to check the LED on the tuning box receives power. Press it to adjust up or down one to test. This information will be important later should you need to contact us.

Second we would suggest to uninstall the product and see if you notice a degradation in vehicle performance.

If with the box removed you feel performance is unchanged then please contact our customer services department, it may be that your unit has developed a fault.

Can't Find What You're Looking For?

Or Call Us On:

Sales:
03332 304 389
Technical:
03332 304 389